flutter_debug_tools 0.0.5+2 copy "flutter_debug_tools: ^0.0.5+2" to clipboard
flutter_debug_tools: ^0.0.5+2 copied to clipboard

discontinuedreplaced by: inspector

A set of tools to help find and debug UI or performance issues from the Flutter app itself.

2
likes
140/ 160
pub points
51%
popularity

We analyzed this package 12 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 18 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_debug_tools, flutter_debug_tools.DebugLoggyPrinter.onLog, flutter_debug_tools.DebugNavigatorObserver, flutter_debug_tools.DebugNavigatorObserver.DebugNavigatorObserver, flutter_debug_tools.DebugNavigatorObserver.updateScreenName.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_debug_tools/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/debug_indicator.dart that imports:
  • package:flutter_debug_tools/src/utils/device_info_manager.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_debug_tools/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/debug_indicator.dart that imports:
  • package:flutter_debug_tools/src/utils/device_info_manager.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_debug_tools/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/debug_indicator.dart that imports:
  • package:flutter_debug_tools/src/utils/device_info_manager.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:flutter_debug_tools/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/debug_indicator.dart that imports:
  • package:flutter_debug_tools/src/utils/device_info_manager.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_debug_tools/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/flutter_debug_tools.dart that imports:
  • package:flutter_debug_tools/src/view/debug_indicator.dart that imports:
  • package:flutter_debug_tools/src/utils/device_info_manager.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus 9.1.1 9.1.1 10.1.0
flutter flutter 0.0.0 0.0.0
loggy ^2.0.3 2.0.3 2.0.3
shared_preferences ^2.2.2 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
stack_trace - 1.11.1 1.11.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `9.1.1` on device_info_plus does not support the stable version `9.1.2`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
51%
popularity

Publisher

verified publisherhashstudios.dev

A set of tools to help find and debug UI or performance issues from the Flutter app itself.

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info_plus, flutter, loggy, shared_preferences

More

Packages that depend on flutter_debug_tools