flutster 1.0.4 copy "flutster: ^1.0.4" to clipboard
flutster: ^1.0.4 copied to clipboard

PlatformAndroid

Record your Flutter UI tests using this Widget on Android. Save the UI tests to play them again automatically.

7
likes
140/ 160
pub points
55%
popularity

We analyzed this package 5 hours ago, and awarded it 140 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/jod-li/flutster/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

203 out of 205 API elements (99.0 %) have documentation comments.

Some symbols that are missing documentation: flutster.FlutsterTestEvent.isStopKey, flutster.FlutsterTestRecord.findEventIndex.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:flutster/flutster.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:flutster/flutster.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:flutster/flutster.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:flutster/flutster.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:flutster/flutster.dart that declares support for platforms: Android.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutster/flutster.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'RawKeyUpEvent' is deprecated and shouldn't be used. Use KeyUpEvent instead. This feature was deprecated after v3.18.0-2.0.pre.

lib/flutster.dart:1069:47

     ╷
1069 │     if (keyEvent is KeyUpEvent || keyEvent is RawKeyUpEvent) {
     │                                               ^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutster.dart

INFO: 'RawKeyDownEvent' is deprecated and shouldn't be used. Use KeyDownEvent instead. This feature was deprecated after v3.18.0-2.0.pre.

lib/flutster.dart:1071:56

     ╷
1071 │     } else if (keyEvent is KeyDownEvent || keyEvent is RawKeyDownEvent) {
     │                                                        ^^^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutster.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive >=3.3.9 <5.0.0 3.6.1 3.6.1
cross_file >=0.3.3+4 <1.0.0 0.3.4+1 0.3.4+1
flutter flutter 0.0.0 0.0.0
flutter_test flutter 0.0.0 0.0.0
http >=0.13.4 <2.0.0 1.2.1 1.2.1
image_compare_2 >=1.1.3 <3.0.0 1.1.7 1.1.7
intl >=0.18.0 <1.0.0 0.19.0 0.19.0
share_plus >=6.3.1 <8.0.0 7.2.2 9.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
image - 4.2.0 4.2.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
share_plus_platform_interface - 3.4.0 4.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
url_launcher_linux - 3.1.1 3.1.1
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 1.0.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=6.3.1 <8.0.0` on share_plus does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions share_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
140
pub points
55%
popularity

Publisher

verified publisherjod.li

Record your Flutter UI tests using this Widget on Android. Save the UI tests to play them again automatically.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

archive, cross_file, flutter, flutter_test, http, image_compare_2, intl, share_plus

More

Packages that depend on flutster