fluent_assertions 0.4.0 icon indicating copy to clipboard operation
fluent_assertions: ^0.4.0 copied to clipboard

Fluent Assertions library written in Dart.

2
likes
120/ 130
pub points
67%
popularity

We analyzed this package 42 hours ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 63 API elements (82.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
test^1.16.51.21.31.21.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-40.0.040.0.0
analyzer-4.1.04.1.0
args-2.3.12.3.1
async-2.9.02.9.0
boolean_selector-2.1.02.1.0
collection-1.16.01.16.0
convert-3.0.23.0.2
coverage-1.4.01.4.0
crypto-3.0.23.0.2
file-6.1.26.1.2
frontend_server_client-2.1.32.1.3
glob-2.1.02.1.0
http_multi_server-3.2.13.2.1
http_parser-4.0.14.0.1
io-1.0.31.0.3
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.120.12.12
meta-1.8.01.8.0
mime-1.0.21.0.2
node_preamble-2.0.12.0.1
package_config-2.1.02.1.0
path-1.8.21.8.2
pool-1.5.11.5.1
pub_semver-2.1.12.1.1
shelf-1.3.11.3.1
shelf_packages_handler-3.0.13.0.1
shelf_static-1.1.11.1.1
shelf_web_socket-1.0.21.0.2
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
test_api-0.4.110.4.11
test_core-0.4.150.4.15
typed_data-1.3.11.3.1
vm_service-9.0.09.0.0
watcher-1.0.11.0.1
web_socket_channel-2.2.02.2.0
webkit_inspection_protocol-1.1.01.1.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.

2
likes
120
pub points
67%
popularity

Publisher

verified publisher iconklisiewicz.dev

Fluent Assertions library written in Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

test

More

Packages that depend on fluent_assertions