firelamp 0.1.0
firelamp: ^0.1.0 copied to clipboard

A flutter package to support CMS(Content Management System) functionalities like user management, forum management, and more for building apps like social apps, shopping apps.

2
likes
100/ 130
pub points
0%
popularity

We analyzed this package 8 hours ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 205 out of 947 API elements (21.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:firelamp/firelamp.dart that imports:
  • package:firelamp/src/api.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 39 issues. Showing the first 2:

lib/src/api.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/api.defines.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.0.03.2.03.2.0
cloud_firestore^2.1.02.5.43.1.4
collection^1.15.0-nullsafety.41.15.01.15.0
dio^4.0.04.0.44.0.4
firebase_auth^1.1.41.4.13.3.3
firebase_core^1.1.11.10.51.10.5
firebase_messaging^9.1.49.1.411.2.3
flutterflutter0.0.00.0.0
flutter_staggered_grid_view^0.4.00.4.10.4.1
get^4.1.44.5.14.5.1
http_parser^4.0.04.0.04.0.0
image_picker^0.7.50.7.5+40.8.4+4
intl^0.17.00.17.00.17.0
path^1.8.01.8.01.8.0
photo_view^0.11.10.11.10.13.0
rxdart^0.27.00.27.30.27.3
scrollable_positioned_list^0.2.0-nullsafety.00.2.30.2.3
shared_preferences^2.0.52.0.92.0.9
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore_platform_interface-5.4.95.4.9
cloud_firestore_web-2.6.42.6.4
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_auth_platform_interface-4.3.16.1.8
firebase_auth_web-1.3.13.3.4
firebase_core_platform_interface-4.2.24.2.2
firebase_core_web-1.5.21.5.2
firebase_messaging_platform_interface-2.1.43.1.3
firebase_messaging_web-1.0.72.2.4
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
meta-1.7.01.7.0
octo_image-1.0.11.0.1
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.0` on cloud_firestore does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^1.1.4` on firebase_auth does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

2
likes
100
pub points
0%
popularity

Publisher

sonub.com

A flutter package to support CMS(Content Management System) functionalities like user management, forum management, and more for building apps like social apps, shopping apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cached_network_image, cloud_firestore, collection, dio, firebase_auth, firebase_core, firebase_messaging, flutter, flutter_staggered_grid_view, get, http_parser, image_picker, intl, path, photo_view, rxdart, scrollable_positioned_list, shared_preferences

More

Packages that depend on firelamp