firebase_dart 0.7.15+4
firebase_dart: ^0.7.15+4 copied to clipboard

A port of the Firebase database client to pure Dart code, usable on different platforms

11
likes
90 / 130
pub points
85 %
popularity

We analyzed this package on Jul 30, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 81 out of 112 API elements (72.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/treestructureddata/value.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async>=1.13.0 <3.0.02.8.12.8.1
collection^1.9.11.15.01.15.0
convert^2.0.02.1.13.0.1
crypto>=2.0.1 <3.0.02.1.53.0.1
dart2_constant^1.0.01.0.2+dart21.0.2+dart2
isolate>=1.1.0 <3.0.02.1.12.1.1
jose^0.1.20.1.2+10.3.2
logging>=0.11.0 <0.12.00.11.41.0.1
meta^1.1.51.7.01.7.0
quiver>=0.22.0 <3.0.02.1.53.0.1
sortedmap^0.4.10.4.2+10.5.1
web_socket_channel>=1.0.4 <2.0.01.2.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
crypto_keys-0.1.40.3.0
matcher-0.12.100.12.10
path-1.8.01.8.0
pointycastle-2.0.13.2.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^2.0.0` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `>=2.0.1 <3.0.0` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

11
likes
90
pub points
85%
popularity

Publisher

appsup.be

A port of the Firebase database client to pure Dart code, usable on different platforms

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

async, collection, convert, crypto, dart2_constant, isolate, jose, logging, meta, quiver, sortedmap, web_socket_channel

More

Packages that depend on firebase_dart