firebase_admin 0.1.4
firebase_admin: ^0.1.4 copied to clipboard

A port of the Firebase admin sdk to pure, idiomatic Dart code

34
likes
80 / 130
pub points
84 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 102 out of 158 API elements (64.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:firebase_admin/firebase_admin.dart that imports:
  • package:firebase_admin/src/auth.dart that imports:
  • package:firebase_admin/src/service.dart that imports:
  • package:firebase_admin/src/app.dart that imports:
  • package:firebase_admin/src/credential.dart that imports:
  • package:firebase_admin/src/auth/credential.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/auth/auth_api_request.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
clock^1.0.01.1.01.1.0
collection^1.14.111.15.01.15.0
crypto_keys^0.1.00.1.30.3.0
dotenv^2.0.02.0.03.0.0
firebase_dart^0.7.15+30.7.15+40.7.15+4
gcloud>=0.6.3 <0.8.00.7.30.8.2
http^0.12.00.12.20.13.3
jose>=0.1.2 <0.3.00.1.2+10.3.2
meta^1.1.61.7.01.7.0
openid_client^0.3.10.3.10.4.1
path^1.6.41.8.01.8.0
x509^0.1.00.1.40.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.2.11.0.1
args-1.6.02.2.0
asn1lib-0.8.11.0.2
async-2.8.12.8.1
built_collection-4.3.25.1.0
built_value-7.1.08.1.1
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
fixnum-0.10.111.0.0
googleapis-0.56.14.0.0
http_parser-3.1.44.0.0
isolate-2.1.12.1.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
pointycastle-1.0.23.2.0
quiver-2.1.53.0.1
sortedmap-0.4.2+10.5.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
web_socket_channel-1.2.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.1.0` on crypto_keys does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions crypto_keys to update the constraint.

The constraint `^2.0.0` on dotenv does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions dotenv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

34
likes
80
pub points
84%
popularity

Publisher

appsup.be

A port of the Firebase admin sdk to pure, idiomatic Dart code

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

clock, collection, crypto_keys, dotenv, firebase_dart, gcloud, http, jose, meta, openid_client, path, x509

More

Packages that depend on firebase_admin