fast_zarinpal 0.1.2 copy "fast_zarinpal: ^0.1.2" to clipboard
fast_zarinpal: ^0.1.2 copied to clipboard

Quick implementation of Zarinpal payments with fast_zarinpal

3
likes
130/ 140
pub points
25%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

31 out of 87 API elements (35.6 %) have documentation comments.

Some symbols that are missing documentation: fast_zarinpal, fast_zarinpal.AnimtedLoading, fast_zarinpal.AnimtedLoading.AnimtedLoading, fast_zarinpal.FastZarinPal, fast_zarinpal.FastZarinPal.FastZarinPal.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fast_zarinpal/fast_zarinpal.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:fast_zarinpal/fast_zarinpal.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:fast_zarinpal/fast_zarinpal.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'subtitle1' is deprecated and shouldn't be used. Use titleMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/fast_zarinpal.dart:97:54

   ╷
97 │                           style: themeData.textTheme.subtitle1,
   │                                                      ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fast_zarinpal.dart

INFO: 'caption' is deprecated and shouldn't be used. Use bodySmall instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/fast_zarinpal.dart:199:64

    ╷
199 │                                                     .textTheme.caption!
    │                                                                ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fast_zarinpal.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cupertino_icons ^1.0.2 1.0.8 1.0.8
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.1 8.1.5 8.1.5
persian_number_utility ^1.1.2 1.1.4 1.1.4
uni_links ^0.5.1 0.5.1 0.5.1
url_launcher ^6.1.7 6.2.6 6.2.6
zarinpal ^1.0.4+1 1.0.5+1 1.0.5+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
bloc - 8.1.4 8.1.4
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
dio - 5.4.3+1 5.4.3+1
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uni_links_platform_interface - 1.0.0 1.0.0
uni_links_web - 0.1.0 0.1.0
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.