facts 1.0.5 icon indicating copy to clipboard operation
facts: ^1.0.5 copied to clipboard

Swagger API client

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package 33 hours ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
0 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 450 out of 2213 API elements (20.3 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:facts/facts.dart that imports:
  • package:facts/model/task_fact.dart that imports:
  • package:sunny_service_stubs/models/reliveit/model/relive_it_contact.dart that imports:
  • package:sunny_service_stubs/models/contact_v2/model/physical_location.dart that imports:
  • package:sunny_sdk_core/sunny_sdk_core.dart that imports:
  • package:sunny_sdk_core/path.dart that imports:
  • package:sunny_sdk_core/model_exports.dart that imports:
  • package:sunny_sdk_core/mverse.dart that imports:
  • package:sunny_sdk_core/mverse/m_base_model.dart that imports:
  • package:sunny_sdk_core/mverse/m_model.dart that imports:
  • package:sunny_sdk_core/mverse/mmodel_registry.dart that imports:
  • package:sunny_sdk_core/api_exports.dart that imports:
  • package:sunny_sdk_core/auth.dart that imports:
  • package:sunny_sdk_core/auth/auth_user_profile.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:facts/facts.dart that imports:
  • package:facts/model/task_fact.dart that imports:
  • package:sunny_service_stubs/models/reliveit/model/relive_it_contact.dart that imports:
  • package:sunny_service_stubs/models/contact_v2/model/physical_location.dart that imports:
  • package:sunny_sdk_core/sunny_sdk_core.dart that imports:
  • package:sunny_sdk_core/path.dart that imports:
  • package:sunny_sdk_core/model_exports.dart that imports:
  • package:sunny_sdk_core/mverse.dart that imports:
  • package:sunny_sdk_core/mverse/m_base_model.dart that imports:
  • package:sunny_sdk_core/mverse/m_model.dart that imports:
  • package:sunny_sdk_core/mverse/mmodel_registry.dart that imports:
  • package:sunny_sdk_core/api_exports.dart that imports:
  • package:sunny_sdk_core/auth.dart that imports:
  • package:sunny_sdk_core/auth/auth_user_profile.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
Package not compatible with platform Web

Because:

  • package:facts/facts.dart that imports:
  • package:facts/model/task_fact.dart that imports:
  • package:sunny_service_stubs/models/reliveit/model/relive_it_contact.dart that imports:
  • package:sunny_service_stubs/models/contact_v2/model/physical_location.dart that imports:
  • package:sunny_sdk_core/sunny_sdk_core.dart that imports:
  • package:sunny_sdk_core/path.dart that imports:
  • package:sunny_sdk_core/model_exports.dart that imports:
  • package:sunny_sdk_core/mverse.dart that imports:
  • package:sunny_sdk_core/mverse/m_base_model.dart that imports:
  • package:sunny_sdk_core/mverse/m_model.dart that imports:
  • package:sunny_sdk_core/mverse/mmodel_registry.dart that imports:
  • package:sunny_sdk_core/api_exports.dart that imports:
  • package:sunny_sdk_core/auth.dart that imports:
  • package:sunny_sdk_core/auth/auth_user_profile.dart that imports:
  • package:firebase_auth/firebase_auth.dart that imports:
  • package:firebase_auth_platform_interface/firebase_auth_platform_interface.dart that imports:
  • package:firebase_auth_platform_interface/src/platform_interface/platform_interface_firebase_auth.dart that imports:
  • package:firebase_auth_platform_interface/src/method_channel/method_channel_firebase_auth.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

lib/api/membership_api.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/mixins/fact_mixin.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
contact_v2^1.1.41.1.41.1.4
dartx^0.7.10.7.11.0.0
dartxx^0.5.3+20.5.40.5.4
equatable^2.0.32.0.32.0.3
flexidate^0.8.0+30.8.0+30.8.0+3
flutterflutter0.0.00.0.0
http^0.13.40.13.40.13.4
m_entity^1.1.41.1.41.1.4
pfile^2.1.0+42.1.0+42.1.0+4
sunny_dart^0.11.0+70.11.0+80.11.0+8
sunny_sdk_core^2.4.0+72.4.0+112.4.0+11
sunny_service_stubs^0.5.0+90.5.0+100.5.0+10
timezone^0.8.00.8.00.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
boolean_selector-2.1.02.1.0
buffer-1.1.11.1.1
characters-1.2.01.2.0
charcode-1.3.11.3.1
chunked_stream-1.4.11.4.1
clock-1.1.01.1.0
collection-1.15.01.15.0
collection_diff-2.0.3+62.0.3+6
collection_diff_worker-0.5.5+70.5.5+7
crypto-3.0.13.0.1
dio2-5.0.0-nullsafety5.0.0-nullsafety
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_auth-3.3.53.3.5
firebase_auth_platform_interface-6.1.106.1.10
firebase_auth_web-3.3.63.3.6
firebase_core-1.11.01.11.0
firebase_core_platform_interface-4.2.34.2.3
firebase_core_web-1.5.31.5.3
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
inflection3-0.5.3+20.5.3+2
info_x-0.8.0+30.8.0+3
intl-0.17.00.17.0
isolates-3.0.3+83.0.3+8
js-0.6.30.6.4
libphonenumber2-2.0.2+22.0.2+2
logging-1.0.21.0.2
logging_config-0.6.7+70.6.7+7
matcher-0.12.110.12.11
meta-1.7.01.7.0
mobx-2.0.6+12.0.6+1
observable_collections-0.7.0+50.7.0+5
path-1.8.01.8.1
path_provider-2.0.82.0.8
path_provider_android-2.0.112.0.11
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.52.1.5
path_provider_macos-2.0.52.0.5
path_provider_platform_interface-2.0.32.0.3
path_provider_windows-2.0.52.0.5
pedantic-1.11.11.11.1
platform-3.1.03.1.0
platform_detect2-1.5.0+21.5.0+2
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
pub_semver-2.1.02.1.0
quiver-3.0.1+13.0.1+1
recase-4.0.04.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.2
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
sunny_data-1.0.0+31.0.0+3
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.30.4.9
time-2.1.02.1.0
typed_data-1.3.01.3.0
uri-1.0.01.0.0
uuid-3.0.53.0.5
vector_math-2.1.12.1.1
win32-2.3.82.3.8
worker_service-0.7.2+150.7.2+15
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.1` on dartx does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions dartx to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.