ez_flutter 0.4.4
ez_flutter: ^0.4.4

Flutter Android iOS web

A collection of widgets, packages and many more usefull things, mixed up in little framework.

6
likes
90 / 110
pub points
71 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 779 out of 981 API elements (79.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:ez_flutter/ez_flutter.dart that imports:
  • package:ez_flutter/src/widgets/ez_flutter_widget.dart that imports:
  • package:ez_flutter/src/widgets/EzGlobalMessageWrapper.dart that imports:
  • package:ez_flutter/src/model/EzSettings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'Typography' is deprecated and shouldn't be used. The default Typography constructor defaults to the 2014 material design defaults. Applications are urged to migrate to Typography.material2018(), or, if the 2014 defaults are desired, to explicitly request them using Typography.material2014(). This feature was deprecated after v1.13.8..

lib/src/utils/EzThemeUtils.dart:41:20

   ╷
41 │         textTheme: Typography(platform: TargetPlatform.android).black,
   │                    ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/EzThemeUtils.dart

INFO: 'hideCurrentSnackBar' is deprecated and shouldn't be used. Use ScaffoldMessenger.hideCurrentSnackBar. This feature was deprecated after v1.23.0-14.0.pre..

lib/src/widgets/EzGlobalMessageWrapper.dart:131:9

    ╷
131 │       ..hideCurrentSnackBar()
    │         ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/widgets/EzGlobalMessageWrapper.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.5.32.6.32.6.3
global_configuration^1.5.01.6.01.6.0
json_annotation>=2.0.0 <=3.0.13.0.13.1.1
logging^0.11.40.11.40.11.4
rxdart^0.23.10.23.10.24.1
shared_preferences^0.5.6+20.5.12+40.5.12+4
Transitive dependencies
PackageConstraintCompatibleLatest
asn1lib-0.6.50.8.1
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.8.0-nullsafety.31.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
pointycastle-1.0.22.0.0
process-3.0.133.0.13
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0 <=3.0.1` on json_annotation does not support the latest published version `3.1.1`

pubspec.yaml:21:20

   ╷
21 │   json_annotation: ">=2.0.0 <=3.0.1"
   │                    ^^^^^^^^^^^^^^^^^
   ╵
The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:19:11

   ╷
19 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
90
pub points
71%
popularity

A collection of widgets, packages and many more usefull things, mixed up in little framework.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

aic7to@gmail.com

License

MIT (LICENSE)

Dependencies

basic_utils, flutter, flutter_localizations, global_configuration, json_annotation, logging, rxdart, shared_preferences

More

Packages that depend on ez_flutter