embrace_ios 1.5.0 copy "embrace_ios: ^1.5.0" to clipboard
embrace_ios: ^1.5.0 copied to clipboard

PlatformiOS

iOS implementation of the embrace plugin as defined by the embrace_platform_interface package.

0
likes
140/ 140
pub points
16%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

43 out of 44 API elements (97.7 %) have documentation comments.

Some symbols that are missing documentation: embrace_ios.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:embrace_ios/embrace_ios.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:embrace_ios/embrace_ios.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:embrace_ios/embrace_ios.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:embrace_ios/embrace_ios.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:embrace_ios/embrace_ios.dart that declares support for platforms: iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
embrace_platform_interface >=1.5.0 <1.6.0 1.5.0 1.5.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
build_daemon - 4.0.1 4.0.1
build_resolvers - 2.4.2 2.4.2
build_runner - 2.4.8 2.4.8
build_runner_core - 7.3.0 7.3.0
build_version - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.1 8.9.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.4 2.3.4
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 3.2.0 3.2.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
shelf - 1.4.1 1.4.1
shelf_web_socket - 1.0.4 1.0.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
timing - 1.0.1 1.0.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.0 0.5.0
web_socket_channel - 2.4.4 2.4.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

0
likes
140
pub points
16%
popularity

Publisher

verified publisherembrace.io

iOS implementation of the embrace plugin as defined by the embrace_platform_interface package.

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

embrace_platform_interface, flutter

More

Packages that depend on embrace_ios