doraemonkit_csx 0.0.2
doraemonkit_csx: ^0.0.2 copied to clipboard

An app development detection tool, based on the Didi Doraemonkit.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 199 out of 986 API elements (20.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:doraemonkit_csx/doraemonkit_csx.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 49 issues. Showing the first 2:

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/kit/apm/apm.dart:127:15

    ╷
127 │               resizeToAvoidBottomPadding: false,
    │               ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/kit/apm/apm.dart

ERROR: The named parameter 'child' isn't defined.

lib/kit/common/basic_clear_cache.dart:84:9

   ╷
84 │         child: Center(
   │         ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/kit/common/basic_clear_cache.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bot_toast^3.0.53.0.54.0.1
date_format^1.0.81.0.92.0.2
flutterflutter0.0.00.0.0
package_info^0.4.3+20.4.3+42.0.0
path_provider^1.6.111.6.282.0.1
permission_handler^5.0.1+15.1.0+26.1.3
qr_code_scanner^0.3.20.3.50.4.0
qr_flutter^3.2.03.2.04.0.0
share^0.6.5+40.6.5+42.0.1
shared_preferences^0.5.12+40.5.12+42.0.5
vm_service^5.5.05.5.06.2.0
wakelock^0.2.1+10.2.1+10.5.0+2
webview_flutter^1.0.71.0.72.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
csslib-0.16.20.17.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.15.0
import_js_library-1.0.21.0.2
js-0.6.30.6.3
meta-1.3.01.3.0
mime-0.9.71.0.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
permission_handler_platform_interface-2.0.23.1.3
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
qr-1.3.02.0.0
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
wakelock_platform_interface-0.1.0+10.2.0
wakelock_web-0.1.0+30.2.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 12 issues. Showing the first 2:

The constraint `^3.0.5` on bot_toast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions bot_toast to update the constraint.

The constraint `^1.0.8` on date_format does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions date_format to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.