document_picker 0.0.5 icon indicating copy to clipboard operation
document_picker: ^0.0.5 copied to clipboard

Flutter plugin to pick, capture images or add signature in your form

2
likes
90/ 130
pub points
72%
popularity

We analyzed this package 21 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 67 API elements (6.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:document_picker/document_picker.dart that imports:
  • package:document_picker/source/profile_picture.dart that imports:
  • package:document_picker/source/services.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/document_picker.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/source/document_view.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotted_border^2.0.02.0.0+22.0.0+2
flutterflutter0.0.00.0.0
image_cropper^1.4.01.4.11.4.1
image_picker^0.8.0+30.8.4+40.8.4+4
path_provider^2.0.22.0.82.0.8
permission_handler^8.0.18.3.08.3.0
signature^4.1.14.1.15.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.83.1.8
async-2.8.22.8.2
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-3.1.13.1.1
image_picker_for_web-2.1.52.1.5
image_picker_platform_interface-2.4.32.4.3
js-0.6.30.6.4
meta-1.7.01.7.0
path-1.8.11.8.1
path_drawing-1.0.01.0.0
path_parsing-1.0.01.0.0
path_provider_android-2.0.112.0.11
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.52.1.5
path_provider_macos-2.0.52.0.5
path_provider_platform_interface-2.0.32.0.3
path_provider_windows-2.0.52.0.5
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1
win32-2.3.62.3.6
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.1.1` on signature does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions signature to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.