dio_cache_interceptor 0.5.1
dio_cache_interceptor: ^0.5.1

Flutter Android iOS

Dio HTTP cache interceptor with multiple stores respecting HTTP directives (ETag, Last-Modified, ...) with options.

1
likes
100 / 110
pub points
64 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 74 out of 93 API elements (79.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dio_cache_interceptor/dio_cache_interceptor.dart that imports:
  • package:dio_cache_interceptor/src/store/db_cache_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.103.0.103.0.10
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
path^1.7.01.7.01.7.0
sqflite^1.3.1+11.3.2+11.3.2+1
uuid^2.2.22.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
http_parser-3.1.43.1.4
source_span-1.7.01.7.0
sqflite_common-1.0.2+11.0.2+1
string_scanner-1.0.51.0.5
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
64%
popularity

Publisher

openapi4j.org

Dio HTTP cache interceptor with multiple stores respecting HTTP directives (ETag, Last-Modified, ...) with options.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

dio, flutter, meta, path, sqflite, uuid

More

Packages that depend on dio_cache_interceptor