dio_cache_interceptor 0.5.1
dio_cache_interceptor: ^0.5.1

Flutter Android iOS

Dio HTTP cache interceptor with multiple stores respecting HTTP directives (ETag, Last-Modified, ...) with options.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  dio_cache_interceptor: ^0.5.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dio_cache_interceptor/dio_cache_interceptor.dart';
1
likes
100
pub points
64%
popularity

Publisher

openapi4j.org

Dio HTTP cache interceptor with multiple stores respecting HTTP directives (ETag, Last-Modified, ...) with options.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

dio, flutter, meta, path, sqflite, uuid

More

Packages that depend on dio_cache_interceptor