derry 1.2.1
derry: ^1.2.1 copied to clipboard

Dart native

A script manager to help you define script shortcuts and use them effortlessly, and performantly.

77
likes
100 / 110
pub points
68 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 64 API elements (84.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:derry/derry.dart that imports:
  • package:derry/src/execute.dart that imports:
  • package:derry/src/bindings/executor.dart that imports:
  • package:derry/src/bindings/get_object.dart that imports:
  • package:derry/models.dart that imports:
  • package:derry/src/models/error.dart that imports:
  • package:derry/error.dart that imports:
  • package:derry/src/error/handler.dart that imports:
  • package:console/console.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.02.0.0
console^3.1.03.1.03.1.0
equatable^1.2.01.2.61.2.6
ffi^0.1.30.1.31.0.0
path^1.7.01.7.01.8.0
string_similarity^1.0.11.1.01.1.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
meta-1.2.41.3.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
vector_math-2.0.82.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.6.0` on args does not support the stable version `2.0.0`, that was published 20 days ago.

When args is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`, that was published 15 days ago.

When ffi is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

77
likes
100
pub points
68%
popularity

Publisher

frenco.dev

A script manager to help you define script shortcuts and use them effortlessly, and performantly.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, console, equatable, ffi, path, string_similarity, yaml

More

Packages that depend on derry