debug_overlay 0.1.2
debug_overlay: ^0.1.2 copied to clipboard

🐛 View debug infos and change settings via a central overlay for your app.

2
likes
120/ 130
pub points
70%
popularity

We analyzed this package 20 hours ago, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 88 API elements (20.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:debug_overlay/debug_overlay.dart that imports:
  • package:debug_overlay/src/helpers/package_info.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus_linux/package_info_plus_linux.dart that imports:
  • package:package_info_plus_linux/src/package_info.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
black_hole_flutter^0.3.00.3.40.3.4
collection^1.15.01.15.01.15.0
data_size^0.2.00.2.00.2.0
device_info_plus^3.0.03.1.13.1.1
flutterflutter0.0.00.0.0
implicitly_animated_list^2.0.02.1.02.1.0
meta^1.3.01.7.01.7.0
package_info_plus^1.0.01.3.01.3.0
shake^2.0.02.0.02.0.0
supercharged^2.0.02.1.12.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
device_info_plus_linux-2.1.02.1.0
device_info_plus_macos-2.2.02.2.0
device_info_plus_platform_interface-2.2.12.2.1
device_info_plus_web-2.1.02.1.0
device_info_plus_windows-2.1.02.1.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
list_diff-2.0.02.0.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
sensors_plus-1.2.11.2.1
sensors_plus_platform_interface-1.1.01.1.0
sensors_plus_web-1.1.01.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
supercharged_dart-2.1.12.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.