datadome_flutter_dio 3.0.0 copy "datadome_flutter_dio: ^3.0.0" to clipboard
datadome_flutter_dio: ^3.0.0 copied to clipboard

A DataDome integration for Flutter - Dio Integration

3
likes
120/ 160
pub points
76%
popularity

We analyzed this package 42 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/DataDome/datadome-flutter-dio was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/DataDome/datadome-flutter-dio/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Documentation URL doesn't exist.

At the time of the analysis https://docs.datadome.co/docs/flutter-dio-plugin was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: datadome_flutter_dio,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

10 out of 106 API elements (9.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: captcha_page, captcha_page.CaptchaPage, captcha_page.CaptchaPage.CaptchaPage, captcha_page.CaptchaPage.captchaUrl, captcha_page.CaptchaPage.isDisplayed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that imports:
  • package:datadome_flutter_dio/tracking/event_tracker.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:datadome_flutter_dio/captcha_page.dart that imports:
  • package:datadome_flutter_dio/tracking/event_tracker.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

WARNING: The left operand can't be null, so the right operand is never executed.

lib/datadome_interceptor.dart:48:49

   ╷
48 │     String cookie = await getDataDomeCookie()?? '';
   │                                                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/datadome_interceptor.dart

WARNING: Dead code.

lib/tracking/event_data.dart:34:9

   ╷
34 │         break;
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/tracking/event_data.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus any 10.1.0 10.1.0
dio ^5.0.0 5.5.0+1 5.5.0+1
flutter flutter 0.0.0 0.0.0
package_info_plus any 8.0.0 8.0.0
platform ^3.1.0 3.1.5 3.1.5
shared_preferences ^2.0.5 2.2.3 2.2.3
webview_flutter ^4.0.0 4.8.0 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
device_info_plus_platform_interface - 7.0.0 7.0.0
dio_web_adapter - 1.0.1 1.0.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.4.0 2.4.0
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0
webview_flutter_android - 3.16.4 3.16.4
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.14.0 3.14.0
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.