cobi_flutter_settings 2.1.1 copy "cobi_flutter_settings: ^2.1.1" to clipboard
cobi_flutter_settings: ^2.1.1 copied to clipboard

An application settings screen for flutter that persists values via the shared_preferences package

3
likes
120/ 140
pub points
22%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

61 out of 82 API elements (74.4 %) have documentation comments.

Some symbols that are missing documentation: cobi_flutter_settings.CustomSetting.onPressed, cobi_flutter_settings.CustomSetting.trailing, cobi_flutter_settings.ImageSetting.showPreview, cobi_flutter_settings.ListItem.caption, cobi_flutter_settings.ListItem.value.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:cobi_flutter_settings/cobi_flutter_settings.dart that imports:
  • package:cobi_flutter_settings/src/widgets/image_setting.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/src/common.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/settings_group.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cross_file ^0.3.2 0.3.4+1 0.3.4+1
flutter flutter 0.0.0 0.0.0
image_picker ^0.8.5 0.8.9 1.1.0
shared_preferences ^2.0.6 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.3+3 0.9.3+3
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
image_picker_android - 0.8.10 0.8.10
image_picker_for_web - 2.2.0 3.0.4
image_picker_ios - 0.8.10 0.8.10
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.10.0 2.10.0
image_picker_windows - 0.2.1+1 0.2.1+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.5` on image_picker does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions image_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

3
likes
120
pub points
22%
popularity

Publisher

unverified uploader

An application settings screen for flutter that persists values via the shared_preferences package

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

cross_file, flutter, image_picker, shared_preferences

More

Packages that depend on cobi_flutter_settings