chat_package 0.0.7
chat_package: ^0.0.7 copied to clipboard

Fully functional chat ui for flutter, with functionality to send text, voice notes,and images

6
likes
120/ 130
pub points
47%
popularity

We analyzed this package on Oct 15, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 58 out of 135 API elements (43.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:chat_package/chat_package.dart that imports:
  • package:chat_package/views/componants/message_widget.dart that imports:
  • package:chat_package/views/componants/audio_message_widget.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_keyboard_visibility^5.0.35.1.05.1.0
flutter_slidable^0.6.00.6.00.6.0
image_picker^0.8.40.8.4+20.8.4+2
intl^0.17.00.17.00.17.0
just_audio^0.9.100.9.130.9.13
permission_handler^8.1.4+28.2.58.2.5
photo_view^0.12.00.12.00.13.0
record^3.0.03.0.03.0.0
stop_watch_timer^1.3.11.3.11.3.1
transparent_image^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
audio_session-0.1.6+10.1.6+1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
cross_file-0.3.1+50.3.1+5
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_keyboard_visibility_platform_interface-2.0.02.0.0
flutter_keyboard_visibility_web-2.0.02.0.0
flutter_plugin_android_lifecycle-2.0.32.0.3
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image_picker_for_web-2.1.32.1.3
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
just_audio_platform_interface-4.0.04.0.0
just_audio_web-0.4.20.4.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
permission_handler_platform_interface-3.7.03.7.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.34.2.3
record_platform_interface-0.1.00.1.0
record_web-0.1.00.1.0
rxdart-0.27.20.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on photo_view does not support the stable version `0.13.0`, that was published 9 days ago.

When photo_view is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.