card91_plugin 0.0.31 copy "card91_plugin: ^0.0.31" to clipboard
card91_plugin: ^0.0.31 copied to clipboard

A card91 common package for different features and services.

1
likes
90/ 140
pub points
59%
popularity

We analyzed this package 21 hours ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

10 out of 136 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: card91_plugin, card91_plugin.Card91CardBalanceWidget, card91_plugin.Card91CardBalanceWidget.Card91CardBalanceWidget, card91_plugin.Card91CardBalanceWidget.cardId, card91_plugin.Card91CardBalanceWidget.env.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:card91_plugin/card91_flutter_library.dart that imports:
  • package:card91_plugin/src/card91_print_card.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 75 issues. Showing the first 2:

WARNING: Unused import: 'response_error.dart'.

lib/src/api_services/api_services.dart:11:8

   ╷
11 │ import 'response_error.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api_services/api_services.dart

WARNING: Dead code.

lib/src/api_services/api_services.dart:38:7

   ╷
38 │       throw ('noInternetConnection'.tr);
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api_services/api_services.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
get ^4.6.1 4.6.6 4.6.6
http ^0.13.4 0.13.6 1.2.1
http_parser ^4.0.2 4.0.2 4.0.2
open_file_safe ^3.2.3 3.2.3 3.2.3
path_provider ^2.0.11 2.0.15 2.1.2
pdf ^3.8.2 3.10.8 3.10.8
webview_flutter ^3.0.4 3.0.4 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
async - 2.11.0 2.11.0
barcode - 2.2.6 2.2.6
bidi - 2.0.10 2.0.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 1.2.1 2.1.2
image - 4.1.7 4.1.7
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.0.7 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.7.4 3.7.4
qr - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.15.0
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.12.0
win32 - 2.6.1 5.2.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.4` on webview_flutter does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

1
likes
90
pub points
59%
popularity

Publisher

verified publishercard91.io

A card91 common package for different features and services.

Homepage

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter, get, http, http_parser, open_file_safe, path_provider, pdf, webview_flutter

More

Packages that depend on card91_plugin