authing_sdk_v3 0.0.1 copy "authing_sdk_v3: ^0.0.1" to clipboard
authing_sdk_v3: ^0.0.1 copied to clipboard

Authing SDK for Flutter. It provides basic authentication APIs, user profile APIs, social connection APIs, Multi-factor Authentication APIs

0
likes
130/ 160
pub points
32%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

55 out of 178 API elements (30.9 %) have documentation comments.

Some symbols that are missing documentation: auth_request, auth_request.AuthRequest, auth_request.AuthRequest.AuthRequest, auth_request.AuthRequest.authingLang, auth_request.AuthRequest.clientId.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:authing_sdk_v3/authing.dart that imports:
  • package:authing_sdk_v3/result.dart that imports:
  • package:authing_sdk_v3/user.dart that imports:
  • package:authing_sdk_v3/client.dart that imports:
  • package:authing_sdk_v3/oidc/oidc_client.dart that imports:
  • package:authing_sdk_v3/oidc/cookie_manager.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Unused import: 'package:authing_sdk_v3/oidc/auth_request.dart'.

lib/result.dart:1:8

  ╷
1 │ import 'package:authing_sdk_v3/oidc/auth_request.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/result.dart

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/util.dart:32:26

   ╷
32 │     String language = ui.window.locale.languageCode;
   │                          ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/util.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.1 3.0.3 3.0.3
encrypt ^5.0.1 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
http ^0.13.4 0.13.6 1.2.1
pointycastle ^3.5.0 3.9.1 3.9.1
shared_preferences ^2.0.0 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
32%
popularity

Publisher

verified publisherflutter.authing.cn

Authing SDK for Flutter. It provides basic authentication APIs, user profile APIs, social connection APIs, Multi-factor Authentication APIs

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, encrypt, flutter, http, pointycastle, shared_preferences

More

Packages that depend on authing_sdk_v3