at_client 3.0.76 copy "at_client: ^3.0.76" to clipboard
at_client: ^3.0.76 copied to clipboard

The at_client library is the non-platform specific Client SDK which provides the essential methods for building an app using the atProtocol.

13
likes
140/ 160
pub points
73%
popularity

We analyzed this package 18 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

596 out of 1174 API elements (50.8 %) have documentation comments.

Some symbols that are missing documentation: at_client, at_client.AtBufferOverFlowException, at_client.AtBufferOverFlowException.AtBufferOverFlowException, at_client.AtBufferOverFlowException.message, at_client.AtChainedException.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:at_client/at_client.dart that imports:
  • package:at_client/src/util/encryption_util.dart that imports:
  • package:at_utils/at_logger.dart that imports:
  • package:at_utils/src/logging/atsignlogger.dart that imports:
  • package:at_utils/src/logging/handlers.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: 'pubKeyCS' is deprecated and shouldn't be used. Use pubKeyHash.

lib/src/decryption_service/shared_key_decryption.dart:54:25

   ╷
54 │         (atKey.metadata.pubKeyCS != null &&
   │                         ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/decryption_service/shared_key_decryption.dart

INFO: 'pubKeyCS' is deprecated and shouldn't be used. Use pubKeyHash.

lib/src/decryption_service/shared_key_decryption.dart:55:28

   ╷
55 │             atKey.metadata.pubKeyCS !=
   │                            ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/decryption_service/shared_key_decryption.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.6.1 3.6.1 3.6.1
asn1lib ^1.5.3 1.5.3 1.5.3
async ^2.9.0 2.11.0 2.11.0
at_auth ^2.0.4 2.0.4 2.0.4
at_base2e15 ^1.0.0 1.0.0 1.0.0
at_chops ^2.0.0 2.0.0 2.0.0
at_commons ^4.0.6 4.0.10 4.0.10
at_lookup ^3.0.46 3.0.47 3.0.47
at_persistence_secondary_server ^3.0.62 3.0.62 3.0.62
at_persistence_spec ^2.0.14 2.0.14 2.0.14
at_utf7 ^1.0.0 1.0.0 1.0.0
at_utils ^3.0.16 3.0.16 3.0.16
collection ^1.16.0 1.19.0 1.19.0
convert ^3.0.2 3.1.1 3.1.1
cron ^0.5.1 0.5.1 0.6.1
crypto ^3.0.3 3.0.3 3.0.3
crypton >=2.1.0 <=2.2.1 2.2.1 2.2.1
encrypt >=5.0.1 <=5.0.3 5.0.3 5.0.3
hive ^2.2.3 2.2.3 2.2.3
http >=0.13.5 <2.0.0 1.2.1 1.2.1
internet_connection_checker ^1.0.0+1 1.0.0+1 1.0.0+1
meta ^1.8.0 1.15.0 1.15.0
path ^1.8.2 1.9.0 1.9.0
uuid ^3.0.7 3.0.7 4.4.0
version ^3.0.2 3.0.2 3.0.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
at_demo_data - 1.0.3 1.0.3
clock - 1.1.1 1.1.1
dart_periphery - 0.9.5 0.9.5
ecdsa - 0.1.0 0.1.0
elliptic - 0.3.10 0.3.10
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
http_parser - 4.1.0 4.1.0
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
mutex - 3.1.0 3.1.0
ninja_asn1 - 2.0.0 2.0.0
platform - 3.1.5 3.1.5
pointycastle - 3.9.1 3.9.1
process - 4.2.4 5.0.2
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.1` on cron does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions cron to update the constraint.

The constraint `^3.0.7` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

13
likes
140
pub points
73%
popularity

Publisher

verified publisheratsign.org

The at_client library is the non-platform specific Client SDK which provides the essential methods for building an app using the atProtocol.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

archive, asn1lib, async, at_auth, at_base2e15, at_chops, at_commons, at_lookup, at_persistence_secondary_server, at_persistence_spec, at_utf7, at_utils, collection, convert, cron, crypto, crypton, encrypt, hive, http, internet_connection_checker, meta, path, uuid, version

More

Packages that depend on at_client