app_store_connect_apis 0.3.0 copy "app_store_connect_apis: ^0.3.0" to clipboard
app_store_connect_apis: ^0.3.0 copied to clipboard

A package for the Apple App Store Connect API. It can be used to automate steps in your build pipeline.

2
likes
130/ 140
pub points
25%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 16 API elements (31.3 %) have documentation comments.

Some symbols that are missing documentation: app_store_connect, app_store_connect.AppStoreConnect, app_store_connect.AppStoreConnect.loadKeyFileContent, app_store_connect.Profile, app_store_connect.Profile.content.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:app_store_connect_apis/app_store_connect.dart that imports:
  • package:app_store_connect_apis/src/app_store_connect.dart that imports:
  • package:app_store_connect_apis/src/builds.dart that imports:
  • package:app_store_connect_apis/src/http_client.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.4 0.13.6 1.2.1
jose ^0.3.2 0.3.4 0.3.4
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto_keys - 0.3.0+1 0.3.0+1
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2
x509 - 0.2.4+2 0.2.4+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

2
likes
130
pub points
25%
popularity

Publisher

verified publishermethodpark.de

A package for the Apple App Store Connect API. It can be used to automate steps in your build pipeline.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

http, jose

More

Packages that depend on app_store_connect_apis