angular 6.0.1
angular: ^6.0.1 copied to clipboard

Fast and productive web framework by Google. Separate, but similar to the JavaScript framework with a similar name.

76
likes
50 / 110
pub points
95 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 185 out of 302 API elements (61.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:angular/angular.dart that imports:
  • package:angular/src/platform/browser/tools/tools.dart that imports:
  • package:angular/src/platform/browser/tools/common_tools.dart that imports:
  • package:angular/src/core/linker/component_factory.dart that imports:
  • package:angular/src/core/linker/views/host_view.dart that imports:
  • package:angular/src/core/linker/views/view.dart that imports:
  • dart:html
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 45 issues. Showing the first 2:

ERROR: Target of URI hasn't been generated: 'modules.template.dart'.

lib/src/bootstrap/modules.dart:21:8

   ╷
21 │ import 'modules.template.dart' as ng;
   │        ^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bootstrap/modules.dart

INFO: 'bootstrapStatic' is deprecated and shouldn't be used. Renamed "runAppLegacy". See "runApp" for the preferred API..

lib/angular.dart:22:64

   ╷
22 │     show runApp, runAppAsync, runAppLegacy, runAppLegacyAsync, bootstrapStatic;
   │                                                                ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angular.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.00.40.61.1.0
angular_ast1.0.11.0.11.0.1
angular_compiler1.0.11.0.11.0.1
build>=1.1.0 <2.0.01.6.21.6.3
build_config>=0.2.6 <2.0.00.4.60.4.6
code_builder^3.0.13.6.03.6.0
collection^1.14.51.14.131.15.0
csslib^0.16.00.16.20.17.0
intl^0.16.00.16.10.17.0
js^0.6.00.6.20.6.3
logging>=0.9.0 <0.12.00.11.41.0.0
meta^1.1.41.2.41.3.0
path^1.6.11.7.01.8.0
source_gen>=0.9.1 <0.10.00.9.10+20.9.10+3
source_span^1.4.01.7.01.8.1
stack_trace^1.9.11.9.61.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.0
charcode-1.1.31.2.0
checked_yaml-1.0.42.0.0
cli_util-0.2.00.3.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart_style-1.3.101.3.14
file-5.2.16.1.0
fixnum-0.10.111.0.0
glob-1.2.02.0.0
json_annotation-3.1.14.0.0
matcher-0.12.90.12.10
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.80.1.8
quiver-2.1.53.0.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.40.0` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.16.0` on csslib does not support the stable version `0.17.0`, that was published 18 days ago.

When csslib is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions csslib to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

76
likes
50
pub points
95%
popularity

Publisher

angulardart.dev

Fast and productive web framework by Google. Separate, but similar to the JavaScript framework with a similar name.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, angular_ast, angular_compiler, build, build_config, code_builder, collection, csslib, intl, js, logging, meta, path, source_gen, source_span, stack_trace

More

Packages that depend on angular