angel_framework 2.1.1
angel_framework: ^2.1.1 copied to clipboard

A high-powered HTTP server with dependency injection, routing and much more.

46
likes
90 / 130
pub points
83 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 339 out of 489 API elements (69.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_framework/angel_framework.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_container^1.0.41.1.01.1.0
angel_http_exception^1.0.01.1.01.1.0
angel_model^1.0.01.0.31.0.3
angel_route^3.0.03.1.0+13.1.0+1
charcode^1.0.01.3.11.3.1
combinator^1.0.01.1.01.1.0
file^5.0.05.2.16.1.2
http2^1.0.01.0.12.0.0
http_parser^3.0.03.1.44.0.0
http_server^0.9.00.9.8+31.0.0
logging>=0.11.3 <1.0.00.11.41.0.1
matcher^0.12.00.12.100.12.10
merge_map^1.0.01.0.21.0.2
meta^1.0.01.4.01.4.0
mime^0.9.30.9.71.0.0
mock_request^1.0.01.0.71.0.7
path^1.0.01.8.01.8.0
quiver_hashcode^2.0.02.0.03.0.0+1
recase^2.0.02.0.14.0.0
stack_trace^1.0.01.10.01.10.0
string_scanner^1.0.01.1.01.1.0
tuple^1.0.01.0.32.0.0
uuid^2.0.0-rc.12.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
intl-0.17.00.17.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^5.0.0` on file does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

The constraint `^1.0.0` on http2 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions http2 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.