angel_model 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

angel_model #

Angel's basic data model class, no longer with the added weight of the whole framework.

import 'package:angel_model/angel_model.dart';

This package was created to prevent dependency collisions with third-party packages.

1.0.3 #

  • idAsInt returns null when id is null.

1.0.2 #

  • idAsInt now uses int.tryParse.

1.0.1 #

  • Add idAsInt.

1.0.0+1 #

  • Update constraint to work with Dart 2.

example/main.dart

import 'package:angel_model/angel_model.dart';

void main() {
  var todo = Todo(id: '34', isComplete: false);
  print(todo.idAsInt == 34);
}

class Todo extends Model {
  String text;

  bool isComplete;

  Todo(
      {String id,
      this.text,
      this.isComplete,
      DateTime createdAt,
      DateTime updatedAt})
      : super(id: id, createdAt: createdAt, updatedAt: updatedAt);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_model: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_model/angel_model.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
67
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <3.0.0
Dev dependencies
pedantic ^1.0.0