angel3_mongo 3.1.0
angel3_mongo: ^3.1.0 copied to clipboard

MongoDB-enabled services for the Angel framework. Well-tested.

0
likes
120/ 130
pub points
21%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 26 API elements (73.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel3_mongo/angel3_mongo.dart that imports:
  • package:angel3_mongo/services.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel3_framework^4.2.04.2.14.2.1
belatuk_json_serializer^5.0.05.0.05.0.0
belatuk_merge_map^3.0.03.0.23.0.2
mongo_dart^0.7.00.7.20.7.2
Transitive dependencies
PackageConstraintCompatibleLatest
angel3_container-3.1.13.1.1
angel3_http_exception-3.0.23.0.2
angel3_mock_request-2.0.22.0.2
angel3_model-3.1.03.1.0
angel3_route-5.2.05.2.0
async-2.8.22.8.2
basic_utils-3.7.03.7.0
belatuk_code_buffer-3.0.23.0.2
belatuk_combinator-3.0.13.0.1
belatuk_http_server-2.1.02.1.0
bson-1.0.31.0.3
buffer-1.1.11.1.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
fixnum-1.0.01.0.0
http2-2.0.02.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
mongo_dart_query-1.0.21.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-3.3.43.3.4
pool-1.5.01.5.0
quiver-3.0.1+13.0.1+1
rational-1.2.11.2.1
recase-4.0.04.0.0
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-2.0.02.0.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.20.4.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.