mongo_dart_query 0.4.1

  • Readme
  • Changelog
  • Installing
  • 71

mongo_dart_query #

Build Status

Query builder for mongo_dart

0.4.1 #

  • class Set of aggregation stages moved to class SetStage to resolve conflict with dart:core library

0.4.0 - September 30th, 2019 (@alexd1971, @vadimtsushko) #

  • Aggregation pipeline builder PR#14

0.3.1 - June 30th, 2018 (@thosakwe, @aemino) #

  • Merged PR #11 from @aemino, which adds Dart 2 fixes for this package, namely coercin of generic types avoiding implicit casts.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mongo_dart_query: ^0.4.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mongo_dart_query/mongo_dart_query.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:mongo_dart_query/mongo_dart_query.dart.

Health suggestions

Fix lib/src/mongo_aggregation/aggregation_base.dart. (-1 points)

Analysis of lib/src/mongo_aggregation/aggregation_base.dart reported 2 hints:

line 88 col 13: DO use curly braces for all flow control structures.

line 90 col 13: DO use curly braces for all flow control structures.

Maintenance suggestions

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mongo_dart_query.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.69.0 <3.0.0
bson ^0.3.2 0.3.2
meta ^1.1.7 1.1.8
Transitive dependencies
collection 1.14.12
fixnum 0.10.11
more 1.18.2
Dev dependencies
test ^1.3.0