amity_sdk 0.35.0 copy "amity_sdk: ^0.35.0" to clipboard
amity_sdk: ^0.35.0 copied to clipboard

The SDK that enables social features such as Feeds, Groups, Profiles, Content Posts, and Social Media Type Interactions

14
likes
90/ 140
pub points
83%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Documentation URL doesn't exist.

At the time of the analysis https://docs.amity.co/social/flutter-beta was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

746 out of 1531 API elements (48.7 %) have documentation comments.

Some symbols that are missing documentation: amity_sdk.AmityAllUserQueryBuilder.getPagingData, amity_sdk.AmityAttachmentCommentCreator, amity_sdk.AmityAttachmentCommentCreator.AmityAttachmentCommentCreator, amity_sdk.AmityAttachmentCommentCreator.text, amity_sdk.AmityAudio.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:amity_sdk/amity_sdk.dart that imports:
  • package:amity_sdk/src/public/public.dart that imports:
  • package:amity_sdk/src/public/token/token.dart that imports:
  • package:amity_sdk/src/public/token/amity_user_token_manager.dart that imports:
  • package:amity_sdk/src/domain/domain.dart that imports:
  • package:amity_sdk/src/domain/usecase/usecase.dart that imports:
  • package:amity_sdk/src/domain/usecase/stream/stream.dart that imports:
  • package:amity_sdk/src/domain/usecase/stream/stream_observe_usecase.dart that imports:
  • package:amity_sdk/src/domain/composer_usecase/stream_composer_usecase.dart that imports:
  • package:amity_sdk/src/domain/model/amity_stream/amity_stream.dart that imports:
  • package:amity_sdk/src/domain/model/amity_user.dart that imports:
  • package:amity_sdk/src/data/data.dart that imports:
  • package:amity_sdk/src/data/repo_impl/repo_impl.dart that imports:
  • package:amity_sdk/src/data/repo_impl/user_repo_impl.dart that imports:
  • package:amity_sdk/src/core/core.dart that imports:
  • package:amity_sdk/src/core/socket/socket.dart that imports:
  • package:amity_sdk/src/core/socket/event/event.dart that imports:
  • package:amity_sdk/src/core/socket/event/post/post.dart that imports:
  • package:amity_sdk/src/core/socket/event/post/post_remove_reaction_event_listener.dart that imports:
  • package:amity_sdk/src/core/socket/event/post/post_event_listener.dart that imports:
  • package:amity_sdk/src/core/service_locator/service_locator.dart that imports:
  • package:amity_sdk/src/core/service_locator/sdk_service_locator.dart that imports:
  • package:amity_sdk/src/domain/repo/tombstone_repo.dart that imports:
  • package:amity_sdk/src/data/data_source/local/db_adapter/tombstone_db_adapter.dart that imports:
  • package:amity_sdk/src/data/data_source/local/base_adapter.dart that imports:
  • package:amity_sdk/src/data/data_source/data_source.dart that imports:
  • package:amity_sdk/src/data/data_source/remote/remote.dart that imports:
  • package:amity_sdk/src/data/data_source/remote/api_interface/api_interface.dart that imports:
  • package:amity_sdk/src/data/data_source/remote/api_interface/message_api_interface.dart that imports:
  • package:amity_sdk/src/core/model/api_request/create_message_request.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 268 issues. Showing the first 2:

WARNING: Unused import: 'package:amity_sdk/src/data/repo_impl/analytics_repo_impl.dart'.

lib/src/core/engine/analytics/capturer/analytics_event_capturer.dart:3:8

  ╷
3 │ import 'package:amity_sdk/src/data/repo_impl/analytics_repo_impl.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/core/engine/analytics/capturer/analytics_event_capturer.dart

WARNING: Unused import: 'package:amity_sdk/src/src.dart'.

lib/src/core/enum/tombstone_type.dart:1:8

  ╷
1 │ import 'package:amity_sdk/src/src.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/core/enum/tombstone_type.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amity_sdk_api ^0.0.3 0.0.3 0.0.3
byte_util ^3.0.0 3.0.0 3.0.0
collection ^1.17.2 1.18.0 1.18.0
dio ^5.4.0 5.4.1 5.4.1
fixnum ^1.1.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
freezed_annotation ^2.4.1 2.4.1 2.4.1
get_it ^7.6.7 7.6.7 7.6.7
hive ^2.2.3 2.2.3 2.2.3
hive_flutter ^1.1.0 1.1.0 1.1.0
mqtt_client ^10.0.3 10.2.0 10.2.0
path_provider ^2.1.2 2.1.2 2.1.2
socket_io_client ^1.0.2 1.0.2 2.0.3+1
uuid ^4.3.3 4.3.3 4.3.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
event_bus - 2.0.0 2.0.0
ffi - 2.1.2 2.1.2
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
socket_io_common - 1.0.1 2.0.3
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_html - 2.2.4 2.2.4
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on socket_io_client does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions socket_io_client to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

14
likes
90
pub points
83%
popularity

Publisher

verified publisheramity.co

The SDK that enables social features such as Feeds, Groups, Profiles, Content Posts, and Social Media Type Interactions

Homepage

Documentation

Documentation
API reference

License

unknown (LICENSE)

Dependencies

amity_sdk_api, byte_util, collection, dio, fixnum, flutter, freezed_annotation, get_it, hive, hive_flutter, mqtt_client, path_provider, socket_io_client, uuid

More

Packages that depend on amity_sdk