am_state 3.5.0 copy "am_state: ^3.5.0" to clipboard
am_state: ^3.5.0 copied to clipboard

A state-management and data providing library. this lib gives (AmDataProvider<T>) as data provider and (AmRefreshWidget<T>) as wrapper to widgets.

12
likes
130/ 140
pub points
0%
popularity

We analyzed this package 29 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

49 out of 71 API elements (69.0 %) have documentation comments.

Some symbols that are missing documentation: am_state, am_state.AmChannel.invokeEvents, am_state.AmChannel.AmChannel.of, am_state.AmChannel.route, am_state.AmController.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Empty catch block.

lib/src/src.dart:383:17

    ╷
383 │     } catch (e) {}
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/src.dart

INFO: Empty catch block.

lib/src/src.dart:395:19

    ╷
395 │       } catch (e) {}
    │                   ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/src.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

12
likes
130
pub points
0%
popularity

Publisher

unverified uploader

A state-management and data providing library. this lib gives (AmDataProvider<T>) as data provider and (AmRefreshWidget<T>) as wrapper to widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on am_state