am_state 3.5.0 copy "am_state: ^3.5.0" to clipboard
am_state: ^3.5.0 copied to clipboard

A state-management and data providing library. this lib gives (AmDataProvider<T>) as data provider and (AmRefreshWidget<T>) as wrapper to widgets.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add am_state

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  am_state: ^3.5.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:am_state/am_state.dart';
12
likes
130
pub points
0%
popularity

Publisher

unverified uploader

A state-management and data providing library. this lib gives (AmDataProvider<T>) as data provider and (AmRefreshWidget<T>) as wrapper to widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on am_state