address_search_field 5.0.3 copy "address_search_field: ^5.0.3" to clipboard
address_search_field: ^5.0.3 copied to clipboard

An address search field which helps to autocomplete an address by a reference. It can be used to get Directions beetwen two points.

92
likes
120/ 140
pub points
91%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

156 out of 156 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:address_search_field/address_search_field.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:address_search_field/address_search_field.dart that declares support for platforms: Android, iOS, Windows, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:address_search_field/address_search_field.dart that imports:
  • package:address_search_field/src/widgets/address_search_dialog.dart that imports:
  • package:address_search_field/src/services/geo_methods.dart that imports:
  • package:address_search_field/src/models/coords.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:address_search_field/address_search_field.dart that imports:
  • package:address_search_field/src/widgets/address_search_dialog.dart that imports:
  • package:address_search_field/src/services/geo_methods.dart that imports:
  • package:address_search_field/src/models/coords.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:address_search_field/address_search_field.dart that imports:
  • package:address_search_field/src/widgets/address_search_dialog.dart that imports:
  • package:address_search_field/src/services/geo_methods.dart that imports:
  • package:address_search_field/src/models/coords.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'hashValues' is deprecated and shouldn't be used. Use Object.hash() instead. This feature was deprecated in v3.1.0-0.0.pre.897.

lib/src/models/address.dart:85:23

   ╷
85 │   int get hashCode => hashValues(coords, bounds, reference, placeId);
   │                       ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/address.dart

INFO: 'hashValues' is deprecated and shouldn't be used. Use Object.hash() instead. This feature was deprecated in v3.1.0-0.0.pre.897.

lib/src/models/bounds.dart:28:23

   ╷
28 │   int get hashCode => hashValues(southwest, northeast);
   │                       ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/bounds.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.6 4.0.6 5.4.1
flutter flutter 0.0.0 0.0.0
flutter_riverpod ^1.0.4 1.0.4 2.4.10
flutter_web_plugins flutter 0.0.0 0.0.0
google_maps_flutter ^2.1.10 2.5.3 2.5.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
flutter_plugin_android_lifecycle - 2.0.17 2.0.17
google_maps - 6.3.0 7.1.0
google_maps_flutter_android - 2.6.2 2.6.2
google_maps_flutter_ios - 2.4.2 2.4.2
google_maps_flutter_platform_interface - 2.4.3 2.4.3
google_maps_flutter_web - 0.5.4+3 0.5.4+3
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
riverpod - 1.0.3 2.5.0
sanitize_html - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
state_notifier - 0.7.2+1 1.0.0
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^1.0.4` on flutter_riverpod does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_riverpod to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

92
likes
120
pub points
91%
popularity

Publisher

verified publisherjostech.dev

An address search field which helps to autocomplete an address by a reference. It can be used to get Directions beetwen two points.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, flutter_riverpod, flutter_web_plugins, google_maps_flutter

More

Packages that depend on address_search_field