updater 0.2.4 copy "updater: ^0.2.4" to clipboard
updater: ^0.2.4 copied to clipboard

A package to check for the custom in-app updates for Flutter.

35
likes
140/ 140
pub points
78%
popularity

We analyzed this package 16 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

28 out of 58 API elements (48.3 %) have documentation comments.

Some symbols that are missing documentation: constants, update_model, update_model.UpdateModel, update_model.UpdateModel.UpdateModel, update_model.UpdateModel.contentText.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:updater/updater.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:updater/updater.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:updater/updater.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:updater/updater.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:updater/updater.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:updater/updater.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.3.4 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
http ^1.1.2 1.2.0 1.2.1
open_filex ^4.3.4 4.4.0 4.4.0
package_info_plus ^5.0.1 5.0.1 7.0.0
path_provider ^2.1.1 2.1.3 2.1.3
platform ^3.1.3 3.1.4 3.1.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.4.2 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.1` on package_info_plus does not support the stable version `6.0.0`, that was published 29 days ago.

When package_info_plus is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

35
likes
140
pub points
78%
popularity

Publisher

verified publishermarsad.dev

A package to check for the custom in-app updates for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, http, open_filex, package_info_plus, path_provider, platform

More

Packages that depend on updater