update_helper 0.1.0 icon indicating copy to clipboard operation
update_helper: ^0.1.0 copied to clipboard

Help you easier to control the update dialog. It also supports the feature that forces the app to update to continue using.

0
likes
140/ 140
pub points
59%
popularity

We analyzed this package 14 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 23 API elements (43.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:update_helper/update_helper.dart that imports:
  • package:update_helper/src/update_helper.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform iOS.

Because:

  • package:update_helper/update_helper.dart that imports:
  • package:update_helper/src/update_helper.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform Linux.

Because:

  • package:update_helper/update_helper.dart that imports:
  • package:update_helper/src/update_helper.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform macOS.

Because:

  • package:update_helper/update_helper.dart that imports:
  • package:update_helper/src/update_helper.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package not compatible with platform Web

Because:

  • package:update_helper/update_helper.dart that imports:
  • package:update_helper/src/update_helper.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_linux.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.13.50.13.50.13.5
package_info_plus^3.0.23.0.23.0.2
satisfied_version^0.1.0+10.1.0+10.1.0+1
universal_platform^1.0.0+11.0.0+11.0.0+1
url_launcher^6.1.76.1.76.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
ffi-2.0.12.0.1
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.24.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
package_info_plus_platform_interface-2.0.12.0.1
path-1.8.21.8.2
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher_android-6.0.226.0.22
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.4
win32-3.1.23.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
140
pub points
59%
popularity

Publisher

verified publisher iconpub.vursin.com

Help you easier to control the update dialog. It also supports the feature that forces the app to update to continue using.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http, package_info_plus, satisfied_version, universal_platform, url_launcher

More

Packages that depend on update_helper