update_available 3.0.1 copy "update_available: ^3.0.1" to clipboard
update_available: ^3.0.1 copied to clipboard

Know if there's any update for your Flutter app, based on published versions.

64
likes
130/ 140
pub points
90%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 10 API elements (80.0 %) have documentation comments.

Some symbols that are missing documentation: update_available, update_available.UpdateAvailablePlatform.getUpdateAvailability.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:update_available/update_available.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:update_available/update_available.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:update_available/update_available.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:update_available/update_available.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/update_available.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
update_available_android ^3.0.0 3.0.1 3.0.1
update_available_ios ^3.0.1 3.0.1 3.0.1
update_available_platform_interface ^4.0.1 4.0.1 4.0.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.0 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_info_plus - 5.0.1 7.0.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.4.2 0.5.1
win32 - 5.4.0 5.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.