unpub 2.0.0
unpub: ^2.0.0 copied to clipboard

Self-hosted private Dart Pub server for Enterprise, with a simple web interface to search and view packages information.

24
likes
100/ 130
pub points
62%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 89 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:unpub/unpub.dart that imports:
  • package:unpub/src/app.dart that imports:
  • package:http/io_client.dart that imports:
  • package:http/src/io_streamed_response.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.1.23.1.63.1.6
args^2.2.02.3.02.3.0
collection^1.15.01.15.01.15.0
googleapis^4.0.04.0.06.0.0
http^0.13.30.13.40.13.4
http_parser^4.0.04.0.04.0.0
intl^0.17.00.17.00.17.0
json_annotation^4.1.04.3.04.3.0
logging^1.0.11.0.21.0.2
meta^1.1.71.7.01.7.0
mime^1.0.01.0.11.0.1
mongo_dart^0.7.10.7.20.7.2
path^1.6.21.8.01.8.0
pub_semver^2.0.02.1.02.1.0
shelf^1.2.01.2.01.2.0
shelf_cors_headers^0.1.20.1.20.1.2
shelf_router^1.1.11.1.11.1.1
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.21.0.2
async-2.8.22.8.2
basic_utils-3.7.03.7.0
bson-1.0.31.0.3
buffer-1.1.11.1.1
charcode-1.3.11.3.1
clock-1.1.01.1.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
fixnum-1.0.01.0.0
http_methods-1.1.01.1.0
js-0.6.30.6.3
mongo_dart_query-1.0.21.0.2
pedantic-1.11.11.11.1
pointycastle-3.3.43.3.4
pool-1.5.01.5.0
rational-1.2.11.2.1
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.20.4.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on googleapis does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

24
likes
100
pub points
62%
popularity

Publisher

opensource.bytedance.com

Self-hosted private Dart Pub server for Enterprise, with a simple web interface to search and view packages information.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, args, collection, googleapis, http, http_parser, intl, json_annotation, logging, meta, mime, mongo_dart, path, pub_semver, shelf, shelf_cors_headers, shelf_router, yaml

More

Packages that depend on unpub