trakt_dart 1.0.0 icon indicating copy to clipboard operation
trakt_dart: ^1.0.0 copied to clipboard

A Dart client-side API package for the Trakt.tv API, a database on what tv shows and movies everyone is watching.

3
likes
110/ 130
pub points
11%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 212 out of 1695 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build_runner^2.1.52.2.02.2.0
dotenv^3.0.03.0.04.0.1
flutterflutter0.0.00.0.0
http^0.13.40.13.50.13.5
json_annotation^4.3.04.6.04.6.0
json_serializable^6.0.16.3.16.3.1
tuple^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-44.0.044.0.0
analyzer-4.4.04.4.0
args-2.3.12.3.1
async-2.9.02.9.0
build-2.3.02.3.0
build_config-1.1.01.1.0
build_daemon-3.1.03.1.0
build_resolvers-2.0.92.0.9
build_runner_core-7.2.37.2.3
built_collection-5.1.15.1.1
built_value-8.4.08.4.0
characters-1.2.01.2.1
checked_yaml-2.0.12.0.1
code_builder-4.2.04.2.0
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
dart_style-2.2.32.2.3
file-6.1.26.1.2
fixnum-1.0.11.0.1
frontend_server_client-2.1.32.1.3
glob-2.1.02.1.0
graphs-2.1.02.1.0
http_multi_server-3.2.13.2.1
http_parser-4.0.14.0.1
io-1.0.31.0.3
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.120.12.12
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
mime-1.0.21.0.2
package_config-2.1.02.1.0
path-1.8.21.8.2
pool-1.5.11.5.1
pub_semver-2.1.12.1.1
pubspec_parse-1.2.01.2.0
quiver-3.1.03.1.0
shelf-1.3.21.3.2
shelf_web_socket-1.0.21.0.2
sky_engine-0.0.990.0.99
source_gen-1.2.21.2.2
source_helper-1.3.21.3.2
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
timing-1.0.01.0.0
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
watcher-1.0.11.0.1
web_socket_channel-2.2.02.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on dotenv does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dotenv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

3
likes
110
pub points
11%
popularity

Publisher

verified publisher icondamonique.dev

A Dart client-side API package for the Trakt.tv API, a database on what tv shows and movies everyone is watching.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

build_runner, dotenv, flutter, http, json_annotation, json_serializable, tuple

More

Packages that depend on trakt_dart