test_reflective_loader 0.1.9

Dart native

Support for discovering tests and test suites using reflection.

0
likes
80 / 110
pub points
52 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 14 API elements (92.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:test_reflective_loader/test_reflective_loader.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/test_reflective_loader.dart:12:1

   ╷
12 │ ┌ /**
13 │ │  * A marker annotation used to annotate test methods which are expected to fail
14 │ │  * when asserts are enabled.
15 │ └  */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/test_reflective_loader.dart

INFO: Avoid const keyword.

lib/test_reflective_loader.dart:16:46

   ╷
16 │ const _AssertFailingTest assertFailingTest = const _AssertFailingTest();
   │                                              ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/test_reflective_loader.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
test>=0.12.0 <2.0.01.15.41.15.4
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-9.0.09.0.0
analyzer-0.40.20.40.2
args-1.6.01.6.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
coverage-0.14.10.14.1
crypto-2.1.52.1.5
glob-1.2.01.2.0
http-0.12.20.12.2
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.180.2.18
test_core-0.3.11+10.3.11+1
typed_data-1.2.01.2.0
vm_service-4.2.05.1.0+1
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.30.7.3
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
52%
popularity

Support for discovering tests and test suites using reflection.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

scheglov@google.com

License

BSD (LICENSE)

Dependencies

test

More

Packages that depend on test_reflective_loader