test 1.15.7
test: ^1.15.7
test: ^1.16.0-nullsafety.12

Dart native js
Flutter Android iOS web

A full featured library for writing and running Dart tests.

90
likes
80 / 110
pub points
98 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:218:1

    ╷
218 │ <a href="http://phantomjs.org/">PhantomJS</a>.</p>
    │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:1043:38

     ╷
1043 │ temporarily to enable use-cases like <a href="http://jasmine.github.io/2.1/focused_specs.html">focusing</a> on a specific test or group.
     │                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.36.0 <0.42.00.41.00.41.0
async^2.0.02.4.22.4.2
boolean_selector>=1.0.0 <3.0.02.0.02.0.0
coverage>=0.13.4 <0.15.00.14.20.14.2
http^0.12.00.12.20.12.2
http_multi_server^2.0.02.2.02.2.0
io^0.3.00.3.40.3.4
js^0.6.00.6.20.6.2
node_preamble^1.3.01.4.121.4.12
package_config^1.9.01.9.31.9.3
path^1.2.01.7.01.7.0
pedantic^1.1.01.9.21.9.2
pool^1.3.01.4.01.4.0
shelf^0.7.00.7.90.7.9
shelf_packages_handler>=1.0.0 <3.0.02.0.02.0.0
shelf_static^0.2.60.2.80.2.8
shelf_web_socket^0.2.00.2.30.2.3
source_span^1.4.01.7.01.7.0
stack_trace^1.9.01.9.61.9.6
stream_channel>=1.7.0 <3.0.02.0.02.0.0
test_api0.2.18+10.2.18+10.2.18+1
test_core0.3.11+40.3.11+40.3.11+4
typed_data^1.0.01.2.01.2.0
web_socket_channel^1.0.01.1.01.1.0
webkit_inspection_protocol>=0.5.0 <0.8.00.7.40.7.4
yaml^2.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-13.0.013.0.0
args-1.6.01.6.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file-5.2.15.2.1
glob-1.2.01.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.41.2.4
mime-0.9.70.9.7
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
pub_semver-1.4.41.4.4
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
vm_service-4.2.05.5.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs