tch_appliable_core 0.9.9
tch_appliable_core: ^0.9.9 copied to clipboard

Flutter core package used by Tomas Chyly & appliable.eu. Contains common functionality to get started faster & consistently.

5
likes
110/ 130
pub points
53%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 239 out of 571 API elements (41.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:tch_appliable_core/tch_appliable_core.dart that imports:
  • package:tch_appliable_core/src/ui/widgets/ScreenMessengerWidget.dart that imports:
  • package:tch_appliable_core/src/core/CoreApp.dart that imports:
  • package:tch_appliable_core/src/providers/MainDataProvider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

lib/src/core/CoreApp.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/core/Preferences.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
html_unescape^2.0.02.0.02.0.0
http^0.13.40.13.40.13.4
intl^0.17.00.17.00.17.0
path^1.8.01.8.01.8.0
path_provider^2.0.52.0.52.0.5
pull_to_refresh^2.0.02.0.02.0.0
sembast^3.1.13.1.13.1.1
shared_preferences^2.0.82.0.82.0.8
sqflite^2.0.0+42.0.0+42.0.0+4
supercharged^2.1.12.1.12.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
supercharged_dart-2.1.12.1.1
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

5
likes
110
pub points
53%
popularity

Publisher

appliable.eu

Flutter core package used by Tomas Chyly & appliable.eu. Contains common functionality to get started faster & consistently.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_localizations, html_unescape, http, intl, path, path_provider, pull_to_refresh, sembast, shared_preferences, sqflite, supercharged

More

Packages that depend on tch_appliable_core