syncfusion_flutter_pdfviewer 19.3.46-beta
syncfusion_flutter_pdfviewer: ^19.3.46-beta copied to clipboard

Flutter PDF Viewer library is used to display a PDF document seamlessly and efficiently.

241
likes
130/ 130
pub points
97%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 95 out of 113 API elements (84.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:syncfusion_flutter_pdfviewer/pdfviewer.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.5.02.8.22.8.2
flutterflutter0.0.00.0.0
http^0.13.00.13.40.13.4
syncfusion_flutter_core^19.3.4619.3.4619.3.46
syncfusion_flutter_pdf^19.3.46-beta19.3.46-beta19.3.46-beta
syncfusion_flutter_pdfviewer_macos^19.3.46-beta19.3.46-beta19.3.46-beta
syncfusion_flutter_pdfviewer_platform_interface^19.3.46-beta19.3.46-beta19.3.46-beta
syncfusion_flutter_pdfviewer_web^19.3.46-beta19.3.46-beta19.3.46-beta
vector_math>=2.1.0 <=3.0.02.1.02.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
petitparser-4.4.04.4.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.