stripe_sdk 4.0.2 icon indicating copy to clipboard operation
stripe_sdk: ^4.0.2 copied to clipboard

The only native Stripe library for Flutter. Has complete support for SCA/PSD2, payment intents and the newest Stripe features.

157
likes
75/ 140
pub points
93%
popularity

We analyzed this package 13 hours ago, and awarded it 75 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

5/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause-Views.

The following license are not OSI-approved: `BSD-2-Clause-Views`.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 66 out of 247 API elements (26.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:stripe_sdk/stripe_sdk.dart that imports:
  • package:stripe_sdk/src/stripe.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:stripe_sdk/stripe_sdk.dart that imports:
  • package:stripe_sdk/src/stripe.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:stripe_sdk/stripe_sdk.dart that imports:
  • package:stripe_sdk/src/stripe.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:stripe_sdk/stripe_sdk.dart that imports:
  • package:stripe_sdk/src/stripe.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

ERROR: 2 positional arguments expected by 'validateCVV', but 1 found.

lib/src/models/card.dart:55:42

   ╷
55 │       return _ccValidator.validateCVV(cvc, cardType: cardType).isValid;
   │                                          ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/card.dart

ERROR: The named parameter 'cardType' isn't defined.

lib/src/models/card.dart:55:44

   ╷
55 │       return _ccValidator.validateCVV(cvc, cardType: cardType).isValid;
   │                                            ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/card.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
awesome_card^1.1.01.1.71.1.7
credit_card_validator^1.1.01.2.02.0.1
flutterflutter0.0.00.0.0
flutter_slidable^0.5.70.5.72.0.0
http^0.12.20.12.20.13.5
mask_text_input_formatter^1.2.11.2.12.4.0
simple_animations^2.4.22.5.15.0.0+3
supercharged^1.12.01.12.02.1.1
uni_links^0.4.00.4.00.5.1
url_launcher^5.7.105.7.106.1.9
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.17.01.17.1
credit_card_type_detector-1.1.02.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.1.3
sa_v1_migration-1.1.21.1.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
supercharged_dart-1.4.02.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher_linux-0.0.1+43.0.2
url_launcher_macos-0.0.1+93.0.2
url_launcher_platform_interface-1.0.92.1.1
url_launcher_web-0.1.5+32.0.14
url_launcher_windows-0.0.1+33.0.3
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.1.0` on credit_card_validator does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions credit_card_validator to update the constraint.

The constraint `^0.5.7` on flutter_slidable does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions flutter_slidable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

157
likes
75
pub points
93%
popularity

Publisher

unverified uploader

The only native Stripe library for Flutter. Has complete support for SCA/PSD2, payment intents and the newest Stripe features.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-2-Clause-Views (LICENSE)

Dependencies

awesome_card, credit_card_validator, flutter, flutter_slidable, http, mask_text_input_formatter, simple_animations, supercharged, uni_links, url_launcher

More

Packages that depend on stripe_sdk