stripe_sdk 4.0.2 icon indicating copy to clipboard operation
stripe_sdk: ^4.0.2 copied to clipboard

The only native Stripe library for Flutter. Has complete support for SCA/PSD2, payment intents and the newest Stripe features.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add stripe_sdk

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  stripe_sdk: ^4.0.2

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:stripe_sdk/stripe_sdk.dart';
157
likes
90
pub points
95%
popularity

The only native Stripe library for Flutter. Has complete support for SCA/PSD2, payment intents and the newest Stripe features.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause-Views (LICENSE)

Dependencies

awesome_card, credit_card_validator, flutter, flutter_slidable, http, mask_text_input_formatter, simple_animations, supercharged, uni_links, url_launcher

More

Packages that depend on stripe_sdk