sqflite_entities 0.0.3+1 copy "sqflite_entities: ^0.0.3+1" to clipboard
sqflite_entities: ^0.0.3+1 copied to clipboard

ORM approach to work with sqflite packages that would allow you to get some ORM practices out of the box for working with classes in the code

8
likes
120/ 140
pub points
13%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 47 API elements (27.7 %) have documentation comments.

Some symbols that are missing documentation: sqflite_entities, sqflite_entities.DatabaseFilePathFactory, sqflite_entities.DatabaseMigration, sqflite_entities.SqlAdapter, sqflite_entities.SqlAdapter.SqlAdapter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:sqflite_entities/sqflite_entities.dart that imports:
  • package:sqflite_entities/src/sqlite_engine.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:sqflite_entities/sqflite_entities.dart that imports:
  • package:sqflite_entities/src/sqlite_engine.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:sqflite_entities/sqflite_entities.dart that imports:
  • package:sqflite_entities/src/sqlite_engine.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Dangling library doc comment.

lib/src/annotations/sql_field_type.dart:3:1

  ╷
3 │ /// Keep in the mind that you can specify some converter function to transform data from/to Model/Sqlite
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/annotations/sql_field_type.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.9.0 5.13.0 6.5.0
build ^2.3.1 2.4.1 2.4.1
build_runner ^2.3.3 2.4.10 2.4.10
flutter flutter 0.0.0 0.0.0
path ^1.8.2 1.9.0 1.9.0
source_gen ^1.2.7 1.5.0 1.5.0
sqflite ^2.2.6 2.3.3+1 2.3.3+1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 68.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build_config - 1.1.1 1.1.1
build_daemon - 4.0.2 4.0.2
build_resolvers - 2.4.2 2.4.2
build_runner_core - 7.3.0 7.3.0
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
shelf - 1.4.1 1.4.1
shelf_web_socket - 2.0.0 2.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite_common - 2.5.4 2.5.4
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
timing - 1.0.1 1.0.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket - 0.1.4 0.1.4
web_socket_channel - 3.0.0 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.9.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

8
likes
120
pub points
13%
popularity

Publisher

verified publishertelequiz.online

ORM approach to work with sqflite packages that would allow you to get some ORM practices out of the box for working with classes in the code

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_runner, flutter, path, source_gen, sqflite

More

Packages that depend on sqflite_entities