siwe_flutter 0.0.13 copy "siwe_flutter: ^0.0.13" to clipboard
siwe_flutter: ^0.0.13 copied to clipboard

A frontend implementation of Sign in With Ethereum for Flutter.

1
likes
120/ 160
pub points
9%
popularity

We analyzed this package 8 hours ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting siwe_flutter... Discovering libraries... Linking elements... Precaching local docs for 1165527 elements... Initialized dartdoc with 1734 libraries Generating docs for library create_external_message.dart from package:siwe_flutter/create_external_message.dart... Generating docs for library sign_message.dart from package:siwe_flutter/sign_message.dart... Generating docs for library create_message.dart from package:siwe_flutter/create_message.dart... Generating docs for library initalize_provider.dart from package:siwe_flutter/initalize_provider.dart... Generating docs for library verify_message.dart from package:siwe_flutter/verify_message.dart... [5 more lines] ERR: The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. [4918 more lines]

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:siwe_flutter/create_external_message.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Windows`.

Because:

  • package:siwe_flutter/create_message.dart that imports:
  • package:siwe_flutter/global.dart that imports:
  • package:walletconnect_qrcode_modal_dart/walletconnect_qrcode_modal_dart.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/wallectconnect_qrcode_modal.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/modal_main_page.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/components/modal_widget.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/components/modal_wallet_list_widget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:siwe_flutter/create_message.dart that imports:
  • package:siwe_flutter/global.dart that imports:
  • package:walletconnect_qrcode_modal_dart/walletconnect_qrcode_modal_dart.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/wallectconnect_qrcode_modal.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/modal_main_page.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/components/modal_widget.dart that imports:
  • package:walletconnect_qrcode_modal_dart/src/components/modal_wallet_list_widget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: Unused import: 'dart:convert'.

lib/get_nonce.dart:1:8

  ╷
1 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/get_nonce.dart

WARNING: Unused import: 'package:web3dart/web3dart.dart'.

lib/global.dart:2:8

  ╷
2 │ import 'package:web3dart/web3dart.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/global.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.6 0.13.6 1.2.1
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
walletconnect_dart ^0.0.11 0.0.11 0.0.11
walletconnect_qrcode_modal_dart ^0.4.1 0.4.3 0.4.3
web3dart ^2.6.1 2.6.1 2.7.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cached_network_image - 3.3.1 3.3.1
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
cryptography - 2.7.0 2.7.0
eip1559 - 0.6.1 0.6.2
eip55 - 1.0.2 1.0.2
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_cache_manager - 3.3.1 3.3.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
json_rpc_2 - 3.0.2 3.0.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
octo_image - 2.0.0 2.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
pointycastle - 3.9.1 3.9.1
qr - 3.0.1 3.0.1
qr_flutter - 4.1.0 4.1.0
rxdart - 0.27.7 0.28.0
sec - 1.1.0 1.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher - 6.3.0 6.3.0
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
wallet - 0.0.13 0.0.13
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.6` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.