rx_bloc 5.0.3 copy "rx_bloc: ^5.0.3" to clipboard
rx_bloc: ^5.0.3 copied to clipboard

A Flutter package that helps implementing the BLoC (Business Logic Component) Design Pattern using the power of reactive streams.

49
likes
160/ 160
pub points
82%
popularity

We analyzed this package 3 days ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/Prime-Holding/rx_bloc/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

71 out of 77 API elements (92.2 %) have documentation comments.

Some symbols that are missing documentation: rx_bloc, rx_bloc.ResultMap, rx_bloc.ResultMapStream, rx_bloc.ResultMapStreamX, rx_bloc.RxBlocTypeBase.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.1 1.19.0 1.19.0
meta ^1.10.0 1.15.0 1.15.0
rxdart ^0.27.7 0.27.7 0.28.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 0 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

49
likes
160
pub points
82%
popularity
screenshot

Publisher

verified publisherprimeholding.com

A Flutter package that helps implementing the BLoC (Business Logic Component) Design Pattern using the power of reactive streams.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, meta, rxdart

More

Packages that depend on rx_bloc