rx_bloc 1.0.1

Flutter Android iOS web

A Flutter package that helps implementing the BLoC (Business Logic Component) Design Pattern using the power of reactive streams.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  rx_bloc: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rx_bloc/rx_bloc.dart';
14
likes
110
pub points
68%
popularity

Publisher

primeholding.com

A Flutter package that helps implementing the BLoC (Business Logic Component) Design Pattern using the power of reactive streams.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, rxdart

More

Packages that depend on rx_bloc