remedi_permission 0.3.1 copy "remedi_permission: ^0.3.1" to clipboard
remedi_permission: ^0.3.1 copied to clipboard

A new Flutter package.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

136 out of 336 API elements (40.5 %) have documentation comments.

Some symbols that are missing documentation: app_permission, app_permission.AppPermission, app_permission.AppPermission.AppPermission, app_permission.AppPermission.description, app_permission.AppPermission.errorDescription.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:remedi_permission/remedi_permission.dart that imports:
  • package:remedi_permission/features/permission_viewmodel.dart that imports:
  • package:remedi_permission/repository/i_permission_repository.dart that imports:
  • package:remedi_permission/model/app_permission.dart that imports:
  • package:notification_permissions/notification_permissions.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:remedi_permission/remedi_permission.dart that imports:
  • package:remedi_permission/features/permission_viewmodel.dart that imports:
  • package:remedi_permission/viewmodel/i_permission_viewmodel.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `macOS`.

Because:

  • package:remedi_permission/remedi_permission.dart that imports:
  • package:remedi_permission/features/permission_viewmodel.dart that imports:
  • package:remedi_permission/viewmodel/i_permission_viewmodel.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `Web`.

Because:

  • package:remedi_permission/remedi_permission.dart that imports:
  • package:remedi_permission/features/permission_viewmodel.dart that imports:
  • package:remedi_permission/viewmodel/i_permission_viewmodel.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: Missing case clause for 'provisional'.

lib/features/permission_viewmodel.dart:29:5

   ╷
29 │     switch (repository.status ?? PermissionStatus.granted) {
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/features/permission_viewmodel.dart

WARNING: Missing case clause for 'provisional'.

lib/features/permission_viewmodel.dart:67:5

   ╷
67 │     switch (status) {
   │     ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/features/permission_viewmodel.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
notification_permissions ^0.6.1 0.6.1 0.6.1
permission_handler ^10.0.0 10.4.5 11.3.0
remedi_widgets ^0.2.1 0.2.4 0.2.4
shared_preferences ^2.0.16 2.2.2 2.2.2
stacked_mvvm ^0.2.0 0.2.1 0.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
base58check - 2.0.0 2.0.0
bech32 - 0.2.2 0.2.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_localizations - 0.0.0 0.0.0
flutter_multi_formatter - 2.12.4 2.12.4
flutter_svg - 1.1.6 2.0.10+1
flutter_web_plugins - 0.0.0 0.0.0
get_it - 7.6.7 7.6.7
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
permission_handler_android - 10.3.6 12.0.5
permission_handler_apple - 9.1.4 9.4.0
permission_handler_platform_interface - 3.12.0 4.2.0
permission_handler_windows - 0.1.3 0.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
rxdart - 0.27.7 0.27.7
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
stacked - 3.4.2 3.4.2
stacked_shared - 1.4.0 1.4.0
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^10.0.0` on permission_handler does not support the stable version `11.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.