pkgraph 2.1.0+1
pkgraph: ^2.1.0+1 copied to clipboard

A tool for studying and visualizing Dart package dependencies.

3
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Avoid const keyword.

lib/src/models/package_version.dart:26:26

   ╷
26 │   @JsonKey(defaultValue: const [], nullable: true)
   │                          ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/models/package_version.dart

lib/src/retry.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.02.0.133.1.2
args^1.5.11.6.02.0.0
http^0.12.00.12.20.13.1
json_annotation^2.0.02.4.04.0.1
logging^0.11.00.11.41.0.1
meta^1.1.01.3.01.3.0
path^1.6.21.8.01.8.0
pub_semver^1.4.01.4.42.0.0
pubspec_parse^0.1.00.1.81.0.0
yaml^2.1.152.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^2.0.0` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^1.5.1` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.