pip_services_email 1.1.1
pip_services_email: ^1.1.1 copied to clipboard

Email Delivery microservice for Pip.Services in Dart. This microservice sends emails to specified recipients.

0
likes
110/ 130
pub points
30%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 66 API elements (18.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pip_services_email/pip_services_email.dart that imports:
  • package:pip_services_email/src/services/version1/service.dart that imports:
  • package:pip_services_email/src/services/version1/EmailHttpServiceV1.dart that imports:
  • package:pip_services3_rpc/pip_services3_rpc.dart that imports:
  • package:pip_services3_rpc/src/build/build.dart that imports:
  • package:pip_services3_rpc/src/build/DefaultRpcFactory.dart that imports:
  • package:pip_services3_rpc/src/services/StatusRestService.dart that imports:
  • package:pip_services3_rpc/src/services/RestService.dart that imports:
  • package:pip_services3_rpc/src/services/HttpResponseSender.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.30.13.40.13.4
logging^1.0.21.0.21.0.2
mailer^5.0.25.0.25.0.2
pip_services3_commons^1.1.51.1.51.1.5
pip_services3_components^1.2.01.2.01.2.0
pip_services3_container^1.1.11.1.11.1.1
pip_services3_data^1.1.21.1.21.1.2
pip_services3_expressions^1.0.11.0.11.0.1
pip_services3_grpc^1.1.11.1.11.1.1
pip_services3_mongodb^1.1.11.1.11.1.1
pip_services3_rpc^1.2.01.2.01.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-30.0.030.0.0
analyzer-2.7.02.7.0
archive-3.1.63.1.6
async-2.8.22.8.2
basic_utils-3.9.13.9.1
bson-1.0.41.0.4
buffer-1.1.11.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
fixnum-1.0.01.0.0
glob-2.0.22.0.2
googleapis_auth-1.3.01.3.0
grpc-3.0.23.0.2
http2-2.0.02.0.0
http_methods-1.1.01.1.0
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
meta-1.7.01.7.0
mime-1.0.11.0.1
mongo_dart-0.7.40.7.4
mongo_dart_query-1.0.21.0.2
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-3.4.03.4.0
pool-1.5.01.5.0
protobuf-2.0.02.0.0
pub_semver-2.1.02.1.0
rational-1.2.11.2.1
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
shelf-1.2.01.2.0
shelf_router-1.1.21.1.2
source_span-1.8.11.8.1
sprintf-6.0.06.0.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.30.4.3
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.